Urgent Evoke

A crash course in changing the world.

Do you have questions about EVOKE?  Check out the new EVOKE FAQ!

The FAQ as it stands is only a start, so we need your help!

What questions and answers do you want to see added to the FAQ?

Post your best frequently asked questions and answers here and they will be added to the official FAQ page.

+1 Knowledge Share for the best answers submissions

Views: 243

Reply to This

Replies to This Discussion

Hi Lauren,

Unfortunatly, I cannot submit the answer to the question, but I have a very important question that should figure in the FAQ.

I just created that account today because my "real" account got disabled for an unknown reason. I did post blogs, no spam, all carefully written and thought for long. Then after posting a blog yesterday (sunday), I got redirected to the signup page. I clicked the login page and when I entered my infos, it said that my account had been disabled.

What can cause that? No warning, impossible to know what went wrong. I did not use bad language, I just can't see any reason for that.

It said that if I thought that the disabling was done by mistake I had to write to Nings. I did it and got no answer after 24 hours. I wrote to Alchemy today and got no answer.

That type of policy should be clearly stated in the FAQ. I feel disappointed and puzzled about that.

Thank you for the enlightment!

P.s. If it can ever help, the email of my disabled account is pacificdave@live.ca
Here's the email I received two days later from Ning:

"Hi there,

Your account was temporarily disabled because our activity filters detected your posted content as spam. We sincerely apologize for this inconvenience, and we have re-enabled your account, so you should be able to sign in without issue. Our spam team is dedicated to keeping each Ning Network safe and will continue to refine our spam settings. Don't hesitate to be in touch if you have any questions.

The Ning Team"

Those "spam" policies should be stated clearly. I don't feel like I've posted anything is row.
Hello, what is the mechanism for getting the points score which is set out on the mission objectives?

Is it just a case of, they will all get "done" before the end of the game? I know there was a statement at one time that evidence would get a****sed in the week after it's posted. I just noticed some of mine haven't got those points, and I think it is more than a week since submitting them.
An example, I just checked my ACT3 post, which says it is worth +10 resourcefulness.

I'm having trouble logging evidence, when I click the link to log it, it brings me down to the bottom where the power votes are but thats all I see.
I've tried this FAQ search


I don't get this "Save" part of it
[Click “Save.” Your Mission has now been logged, your Mission Rune will light up, and it will now show up as a link in the Evidence Log of your “My Profile” page. ]

But still seem to face the same problem you have Kate.

Any help would be appreciated.

kate said:
I'm having trouble logging evidence, when I click the link to log it, it brings me down to the bottom where the power votes are but thats all I see.
I've asked around and apparently no judging of evidence is taking place at this time, so don't count on getting the mission obejctive points. They are intended to be hypothetical, to judge the kind of impact we ought to be aiming for if we take on the objective, and to help us plan our own EVOKE journeys.

Hope that helps.
Richard Escobedo said:
I've joined the party a bit late - how do I see prior graphic novels to catch up with the story?

Hi Richard! Welcome to EVOKE.
I noticed that the Facebook group links the episodes as bit.ly links in a form like this:
http://bit.ly/evoke8p1 so if you use that format you should get episode one page one at bit.ly/evoke1p1 and so on : 1 2 3 4 5 6 7.
I'm sure you can generate the rest yourself. Does that work?

I've been trying to put blog posts to complete missions.
However, when I go to the mission page and click "blog post" and publish my post,
it says the post is up under "my blog," but when i click "edit blog posts" it says there are no blog posts.

When i went to my profile, it said I had no blog posts so I clicked "add blog post"
and the post that I uploaded through that link worked. But all the other posts are not being registered.

How can I solve this problem? its making me really frustrated..

The Urgent Evoke project finished a long time ago. You can no longer complete missions

Reply to Discussion


Latest Activity

Amy Ward-Bailey updated their profile
Mar 25
Yemisi Ajumobi shared their blog post on Facebook
Mar 16
Dante Ranieri shared a profile on Facebook
Sep 4, 2018
Patricio Buenrostro-Gilhuys shared a profile on Facebook
May 6, 2018
Nathan L Verrill posted a blog post

We were hacked!

Citizen X has returned somehow, we don't know how and we are working feverishly to stop him.See More
Oct 17, 2017
Niloc Htael updated their profile
May 16, 2017
Sina shared their video on Facebook
May 9, 2017
Nathan Papke shared their blog post on Facebook
Dec 7, 2016
Christine Nderitu updated their profile
Sep 10, 2016
Christine Nderitu posted a photo


Warm regards,Christine NderituRecreation consultant+1 978 810 2444"Let us step into the night and pursue that flighty temptress, adventure."- J.K Rowling, Harry Potter and The Half Blood Prince
Sep 10, 2016
Ace5 updated their profile
Jan 14, 2016
Ace5 is now a member of Urgent Evoke
Jan 13, 2016
Namwaka Mooto posted blog posts
Jan 13, 2016
Nicholas Dwork updated their profile
Oct 4, 2015
Nicholas Dwork is now a member of Urgent Evoke
Oct 1, 2015
Gary updated their profile
Sep 27, 2015

Follow EVOKE on Twitter

Official EVOKE Facebook Page

EVOKE RSS Activity Feed

© 2019   Created by Alchemy.   Powered by

Badges  |  Report an Issue  |  Terms of Service